Scheduled Maintenance
Incident Report for Zenbu
Resolved
This incident has been resolved.
Posted about 3 years ago. Jul 22, 2015 - 16:49 CEST
Update
- And we are back!
Posted about 3 years ago. Jul 22, 2015 - 16:49 CEST
Investigating
We are currently upgrading new awesome features to Zenbu. - Thank you for your patience!
Posted about 3 years ago. Jul 22, 2015 - 15:25 CEST